個人アプリ開発で月収5万円目指す

アプリ個人開発 まるブログ

アプリ開発覚え書き

iOS14.5のテストビルドにはmacOS Big SurとXcode12.5が必要です。

はじめに

iOS14.5のテストビルドに少しつまづいた話です。

教訓

最初に今回の教訓だけ言います。
Xcode12.5はこのリンクからアップデートしましょう!

Xcode

Xcode

  • Apple
  • 開発ツール
  • 無料
apps.apple.com

iOS14.5テストビルドに必要なもの

iOS14.5テストビルドに必要なものは以下です。

macOS Big Sur(ビッグサー)
・Xcode12.5

なので、macOSがCatalina(カタリナ)なのであればOSのアップデートが必要です。
その後にXcodeをバージョンアップする必要があります。

ちなみに、
iPhoneをiOS14.5にアップデート後は、
古いXcodeバージョンでビルドしようすると怒られます。

f:id:marumaro7:20210501053410p:plain

問題:Xcodeをアップデートしたのにビルドできない

XcodeをデスクトップのAppStoreから検索してアップグレードしました。

だがしかし!

同じエラーが出てビルドができませんでした!

f:id:marumaro7:20210501053410p:plain

Xcodeのアップデート情報を見ると、

サポートはiOS14.4までとなっています・・・

Xcodeは、もうこれ以上アップデートできない・・・

え?詰んだ?\(^o^)/

iOS14.5に対応しているXcode12.5が実はあった!

ネットを徘徊していると
ここにiOS14.5に対応しているXcode12.5がありました!

Xcode

Xcode

  • Apple
  • 開発ツール
  • 無料
apps.apple.com

Xcode12.5がリリースされたのが4日前とのことだったので
ストアに反映されていなかっただけのようです。

おわりに

無駄にXcodeのアップデートしちゃった